October 22, 2021, 01:32:54 AM

News:

Welcome to week4paug.net 2.1 - same as it ever was! Most features have been restored, but please keep us posted on ANY issues you may be having HERE:  https://week4paug.net/index.php/topic,23937


Apple TV troubleshooting

Started by VDB, January 28, 2018, 01:41:41 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

VDB

My Apple TV (3rd gen) has been on the fritz recently. It will lose internet connection even though it stays on the local network (wifi); later it'll work as usual; later it'll fuck up again.

Everything else on the network (including an ATV2) is doing fine. The router is an Airport Extreme.

It's definitely on the local network because the router sees it and I can even Airplay mirror to it. (When I try to go full Airplay it craps out. Maybe the Airplay protocol hands over the connection to the ATV when you go full-screen i.e. not just mirroring?)

This is one of those obnoxious cases where I have changed nothing that would precipitate the malfunction. It literally works and doesn't work at will.

I'd love to try a factory restore, but that requires an internet connection (ha). I don't have cables long enough to haul this thing upstairs and connect it to my router and a TV at the same time without moving a bunch of shit around.

Just curious if anyone else has gone through this, and if so, how or whether you solved it.
Is this still Wombat?

Caravan2001

Have you powered down all the way?  I would at least do a restart on the Apple TV and as well, a full (hard) restart on your computer.  Also make sure your iTunes is up to date.  I have not had this particular problem but I have been through a lot of weird stuff and sometimes just rebooting everything involved does the trick.  Good luck.


tet

I've had similar issues with disconnects and such over the years with Airport base stations, and finally a few months ago, gave up on them after nothing worked (I once swapped hardware and that helped for a few months, until it came back). The hardware is old, the technology in them is old, and they are apparently quite prone to failure.  I now use Plume, which is expensive as you need to buy a lot of them, but it gives me awesome access in every room of my house.  My Apple TV and Xbox haven't disconnected even once since I've made the switch. 
"We want you to be happy"
-Phish

mattstick

I also switched away from Apple Wireless routers and have had fewer issues since.


VDB

Quote from: mattstick on January 29, 2018, 04:41:03 AM
I also switched away from Apple Wireless routers and have had fewer issues since.

Interesting. But "it just works"!

I've also had problems with getting my printer to consistently work on the network (via ethernet). It'll work just fine and then nope. Wonder if it's all related.

In the past, a simple reboot has often worked with ATV problems, but it wasn't helping yesterday.

Strangely, my wife pointed out that our recent ATV problems have coincided with me leaving the house with my laptop, which is ordinarily connected via cord to the router and also wifi for Airdrop purposes. Last night, after I tinkered with the ATV for a while, including manually assigning it an IP address, I again took my MBP off ethernet, then switched one other thing (which had already been tried to no avail) on the ATV, and it worked again. The causality, if there is one, would be inexplicable, but then again so is the fact that this just cuts in and out at random. Last night, though, although it got back on the internet, it had trouble maintaining a connection for a bit, even on the local network (as confirmed by its inability to even play music from the computer without interruption). Well, at least a factory restore may be now back on the table.

Matt, what router do you have?
Is this still Wombat?